WEB开发者-分享WEB开发知识,让开发变得更简单!

你是否在composer安装插件时遇到内存不足的问题?

本文由composer教程栏目给大家介绍关于composer安装插件出现内存不足问题,希望对需要的朋友有所帮助!

你是否在composer安装插件时遇到内存不足的问题?

composer安装插件出现内存不足问题

近期用命令composer require phpoffice/phpspreadsheet安装phpspreadsheet时出现内存不足问题,出现如下错误:

The following exception is caused by a lack of memory or swap, or not having swap configured

用以下方法完美解决:

sudo /bin/dd if=/dev/zero of=/var/swap.1 bs=1M count=1024  
sudo /sbin/mkswap /var/swap.1
sudo /sbin/swapon /var/swap.1

composer简介:

Composer 是 PHP5.3以上 的一个依赖管理工具。它允许你声明项目所依赖的代码库,它会在你的项目中为你安装他们。Composer 不是一个包管理器。是的,它涉及 "packages" 和 "libraries",但它在每个项目的基础上进行管理,在你项目的某个目录中(例如 vendor)进行安装。默认情况下它不会在全局安装任何东西。因此,这仅仅是一个依赖管理。

更多composer相关技术文章,请访问composer教程栏目!

以上就是你是否在composer安装插件时遇到内存不足的问题?的详细内容,更多请关注web开发者其它相关文章!

本文链接:https://www.webkfz.com/diannaojiqiao/180261.html

版权声明:站内所有文章皆来自网络转载,只供分享作用,不代表本站的观点!

发表评论 共有 0 条评论)

联系客服
网站客服 业务合作 QQ
1244305267
公众号
公众号
公众号
返回顶部